"One day you are a signature, next day you are an autograph." —Billy Wilder

General DiscussionsWhat the hell!!

Post Reply
User avatar
pop511
Mentoris Dominus
Mentoris Dominus
Posts: 550
Joined: Sat Dec 13, 2014 2:29 am
Location: Sydney,Australia
Social Media Opt-In: Yes
Editing option: Yes, feel free to edit my image
Contact:

What the hell!!

Post by pop511 » Fri Aug 24, 2018 7:52 am

Have Canon speedlights and also a Phottix speedlight.
The Phottix unit precedes the latest version where transceivers are in the unit.
All flashes are fired with Phottix Odins.
I'm going to shoot at a dinner and ball tomorrow and so, yours truly has to wear a suit and tie...YuK!

Above comments are for explanation purposes only as shall be explained.

Turn on the Phottix, 2-3 seconds it is ready to go. Press the test button and it wont fire.
If I connect to camera. Nothing
This the second time this has happened and is both annoying and worrying.
30 minutes later where I am about to throw it out the window, I get a small flash, next press on the test button and all seems normal, and so it is.
Works perfectly on camera and exposure spot on.
So what the hell is going on. Capacitor charge circuit in flash? If so, then why do the lights on the back of the unit show no problem.
Got any tech_heads out there?
Interim fix? Leave it out with batteries installed and fire it off once a day?
ed davis

User avatar
minniev
Mentoris Magister
Mentoris Magister
Posts: 3911
Joined: Sun Apr 17, 2016 3:55 am
Location: Mississippi
Social Media Opt-In: Yes
Editing option: Yes, feel free to edit my image
Contact:

Post by minniev » Fri Aug 24, 2018 9:23 pm

Wish I could help but I'm a flash dummy. Maybe Duck'll show up...
"God gave me photography so that I could pray with my eyes" - Dewitt Jones

User avatar
pop511
Mentoris Dominus
Mentoris Dominus
Posts: 550
Joined: Sat Dec 13, 2014 2:29 am
Location: Sydney,Australia
Social Media Opt-In: Yes
Editing option: Yes, feel free to edit my image
Contact:

Post by pop511 » Fri Aug 24, 2018 10:08 pm

Have been playing with it all night. Turning it on and off. Working perfectly.
ed davis

User avatar
St3v3M
Key Founding Member
Key Founding Member
Posts: 4328
Joined: Sun Apr 17, 2016 1:02 am
Location: 35,000 feet
Social Media Opt-In: Yes
Editing option: Yes, feel free to edit my image
Contact:

Post by St3v3M » Mon Aug 27, 2018 1:56 am

I've yet to use a flash either. Google? S-
"Take photographs, leave footprints, steal hearts"

Who is online

Users browsing this forum: No registered users and 3 guests